Configure NAT/PAT to Access Internet

We need to configure NAT/PAT on the interfaces of the router to
have access to internet.

See below image for reference.


Configure Static Route.
Router#
Router#conf t
Router(config)#
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1
Note. 192.168.1.1 is the given gateway IP address of the ISP

Configure ISP's IP address and NAT on the interface fa0/0.
Router(config)#int fa0/0
Router(config-if)#description WAN
Router(config-if)#ip address 192.168.10.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#ip nat outside
Router(config-if)#exit

Configure IP address and NAT for local area network.
Router(config)#
Router(config)#int fa0/1
Router(config-if)#description LAN
Router(config-if)#ip address 10.0.10.1 255.255.255.0
Router(config-if)#ip nat inside
Router(config-if)#no shutdown
Router(config-if)#exit

Configure Access Control List and PAT to connect to internet.
Router(config)#ip access-list standard LAN
Router(config-std-nacl)#permit 10.0.10.0 0.0.0.255
Router(config-std-nacl)#exit
Router(config)#ip nat inside source list LAN int fa0/0 overload
Router(config)#exit
Router#copy run start

Since DHCP server was not configured on the router,you need to configure manually
the IP address of all computers on the network . The IP address 10.0.10.1 will be
your default gateway.

          <Previous  Next>                                          

0 Comments:

Post a Comment